In the twenty years I have now been working on cars, I have achieved a good deal of success. Brake jobs, every bit of suspension, thermostats and water pumps, more intricate things like valve timing solenoids, and even cambelts – I have done them all and been able to make cars run and drive better. But automotive electrics remains one area I do not have a good working knowledge of, or much experience with, having only ventured into doing simple things, like repairing frayed wiring on a boot lid release.

Still, how are you going to learn if you don’t try? The radio display on my Subaru Outback has not worked since the day I bought the car. This has not bothered me, as I don’t use the radio, but instead use my phone to stream music through the Bluetooth setup the previous owner installed. But every now and then I get an itch to take stuff apart and tinker, and so I figured it was time to have a go at fixing the radio display.

If you jump on the forums, you will discover that a blank radio display is a common issue on the BL/BP-series Outback and Legacy, and nobody has really found a definitive fix for it. Part of the problem is that it seems to be caused by different issues for different people. Some report resistors coming apart from the circuit board, which are easily soldered back into place, while others report corrosion and oxidation on the grounds as the possible cause, a problem that is more difficult to isolate. Few seem to have found a long-term solution.

Largely unaware of what I would be looking for, or what I would do when I found it, I nonetheless decided to take the radio unit apart and see if I could make any sense what was going on. Pulling the radio out of the centre console is easy enough, and involves removing a few pieces of trim and a number of screws (there is a tutorial here). Once you’ve done it for the first time, you can have it out in two minutes the next time. Even getting to the circuit board is easy – just four screws hold the display and main circuit board to the unit.

Once it was open, I started analysing the board. I know what a circuit board looks like, but I don’t really know what a circuit board is not supposed to look like. Without any help, I would have probably expected black marks from where something exploded and caught fire. But as you do in these circumstances, I went to Twitter, and enlisted the help of Glenn9K, who I know does a lot of work with electrical stuff. All I could do was share a photo of the circuit board, but in doing so, he wasn’t able to detect anything obviously wrong.

On further advice, I ended up looking for signs of oxidation and corrosion, and once I knew what those looked like (thanks, Google), I started to see signs of it all over the board. I took a pick – probably an unorthodox method – and started to very lightly scrape off the corrosion. When I started doing that, I couldn’t believe how much was actually there. After finishing, I blew the dust off the board, and cleaned it with contact cleaner and isopropyl alcohol, again surprised at the dirt that the cotton swab was picking up.

When I put everything back together and reinstalled the unit in the car, the display was working, although my success was short-lived, because once I’d reinstalled the trim, it went blank again. Someone else on Twitter suggested the problem might be with the screen itself, and that I might need to lift it up and reset it on the board. I took the unit apart again and did just that, and after reinstalling it and all the trim, it looked to be in working order. I left the display on for thirty minutes, with no flickering or interruptions.

I wish I could say that is the end of the story, but I got back in the next day, and the display had stopped working again. At this point, I’m not really sure what to do, because I am already in over my head, and don’t want to go any deeper into the circuit board. As it is right now, everything besides the one display still works. And again, since I don’t use the radio itself, I’m content to concede defeat at this point. (Insert some philosophical discussion here about how it is important to fail sometimes). But in the meantime, if you have any other suggestions for how I might get this display working again, they are most welcome.

Advertisements

One thought on “A display of failure

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s